Results 1 to 3 of 3

Thread: mono upgrade ./config errors

  1. #1

    Default mono upgrade ./config errors

    I'm trying to upgrade mono to 2.4.2 and have the source from Novell. When I try to run ./configure --with-libgdiplus=yes I get the following errors.


    ./configure: line 24704: cd: ../libgdiplus: No such file or directory
    checking for pkg-config... /usr/bin/pkg-config
    Package glib-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `glib-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'glib-2.0' found
    Package gthread-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gthread-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gthread-2.0' found
    Package glib-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `glib-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'glib-2.0' found
    Package gthread-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gthread-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gthread-2.0' found
    configure: error: You need at least glib-2.0 1.3.11

    I'm pretty new to linux still and have only a dim idea of what this means. Any advice or interpretation appreciated.

    Tom

  2. #2
    Join Date
    Jul 2009
    Location
    New York
    Posts
    464

    Default

    it's ether you need the glib-devel or upgrade your gtk

  3. #3
    Join Date
    Jul 2007
    Location
    127.0.0.1
    Posts
    392

    Default

    Quote Originally Posted by Tom Sullivan View Post
    Any advice or interpretation appreciated.
    Greeting Tom,

    Welcome to the wonderful world of l00nix. The error you're seeing basically says: I can't find the software/package/application needed to finish the config command.

    This is a fairly easy one to resolve. If you're running Debian Lenny, try this:
    Code:
     rewt@bawxn ~# aptitude install libc6
    You're probably wondering where libc6 came from, so to answer that, let's search for the missing package:
    Code:
    rewt@bawxn ~# aptitude search glibc-2.7-1
    v - glibc-2.7-1
    rewt@bawxn ~#
    Great, we found it. Let's see what the heck glibc-2.7-1 is:
    Code:
    rewt@bawxn ~# aptitude show glibc-2.7-1
    No current or candidate version found for glibc-2.7-1
    Package: glibc-2.7-1
    State: not a real package
    Provided by: libc6
    rewt@bawxn ~#
    Not a real package?? Don't be alarmed - the "v" from the first command indicates a "virtual" package I believe. Think of it as an alias... Aptitude did tell us the package libc6 provides what we're looking for (glib-2....) Let's see what the heck libc6 is:
    Code:
    rewt@bawxn ~# aptitude show libc6
    Package: libc6
    State: not installed
    Automatically installed: no
    Version: 2.7-18
    Priority: required
    Section: libs
    Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
    Uncompressed Size: 11.7M
    Depends: libgcc1
    Suggests: locales, glibc-doc
    Conflicts: libterm-readline-gnu-perl (< 1.15-2), tzdata (< 2007k-1), tzdata-etch
    Provides: glibc-2.7-1
    Description: GNU C Library: Shared libraries
     Contains the standard libraries that are used by nearly all programs on the system. This package includes shared versions of the standard C library and the standard math library, as well as many others.
    
    rewt@bawxn ~#
    That's what we need. Notice the line: Provides: glib-2.7-1? Now, let's resolve your issue.

    Code:
    rewt@bawxn ~# aptitude update; aptitude install libc6
    Once that finishes, try running your configure command again and let us know how it turns out.

    -Guy

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •