Results 1 to 2 of 2

Thread: Unable to update Centos

  1. #1
    Join Date
    Dec 2009
    Posts
    1

    Default Unable to update Centos

    Help ...

    I am unable to update Centos 5.3 using the command, "yum -y update." When doing so, I receive the long message below. I have also tried "yum clean all,"yum clean metadata" and "yum update kernel." The server has 256 MB and my only interest is keeping up with security updates before I get hacked. Any and all suggestions welcome.

    Thanks in advance.

    PS ... Keep it simple as I am not a Linux guru.


    > yum update
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Excluding Packages in global exclude list
    Finished
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package psmisc.i386 0:22.2-7 set to be updated
    ---> Package libsemanage.i386 0:1.9.1-4.4.el5 set to be updated
    ---> Package libselinux.i386 0:1.33.4-5.5.el5 set to be updated
    ---> Package libgomp.i386 0:4.4.0-6.el5 set to be updated
    ---> Package openssh.i386 0:4.3p2-36.el5_4.2 set to be updated
    ---> Package rpm-python.i386 0:4.4.2.3-18.el5 set to be updated
    ---> Package popt.i386 0:1.10.2.3-18.el5 set to be updated
    ---> Package util-linux.i386 0:2.13-0.52.el5 set to be updated
    ---> Package e2fsprogs-libs.i386 0:1.39-23.el5 set to be updated
    ---> Package initscripts.i386 0:8.45.30-2.el5.centos set to be updated
    ---> Package module-init-tools.i386 0:3.3-0.pre3.1.54.el5 set to be updated
    --> Processing Dependency: mkinitrd for package: module-init-tools
    ---> Package cyrus-sasl-lib.i386 0:2.1.22-5.el5 set to be updated
    ---> Package mlocate.i386 0:0.15-1.el5.2 set to be updated
    ---> Package rpm-libs.i386 0:4.4.2.3-18.el5 set to be updated
    ---> Package findutils.i386 1:4.2.27-6.el5 set to be updated
    ---> Package audit-libs-python.i386 0:1.7.13-2.el5 set to be updated
    ---> Package httpd-manual.i386 0:2.2.3-31.el5.centos.2 set to be updated
    ---> Package cups-libs.i386 1:1.3.7-11.el5_4.4 set to be updated
    ---> Package device-mapper.i386 0:1.02.32-1.el5 set to be updated
    ---> Package libstdc++.i386 0:4.1.2-46.el5_4.1 set to be updated
    ---> Package cyrus-sasl-gssapi.i386 0:2.1.22-5.el5 set to be updated
    ---> Package iputils.i386 0:20020927-46.el5 set to be updated
    ---> Package ethtool.i386 0:6-3.el5 set to be updated
    ---> Package caching-nameserver.i386 30:9.3.6-4.P1.el5 set to be updated
    ---> Package readline.i386 0:5.1-3.el5 set to be updated
    ---> Package tcl.i386 0:8.4.13-4.el5 set to be updated
    ---> Package cyrus-sasl-plain.i386 0:2.1.22-5.el5 set to be updated
    ---> Package sqlite.i386 0:3.3.6-5 set to be updated
    ---> Package binutils.i386 0:2.17.50.0.6-12.el5 set to be updated
    ---> Package perl.i386 4:5.8.8-27.el5 set to be updated
    ---> Package netpbm.i386 0:10.35.58-8.el5 set to be updated
    ---> Package libselinux-python.i386 0:1.33.4-5.5.el5 set to be updated
    ---> Package fuse.i386 0:2.7.4-8.el5 set to be updated
    --> Processing Dependency: kernel >= 2.6.14 for package: fuse
    --> Processing Dependency: which for package: fuse
    ---> Package db4.i386 0:4.3.29-10.el5 set to be updated
    ---> Package policycoreutils.i386 0:1.33.12-14.6.el5 set to be updated
    ---> Package openswan-doc.i386 0:2.6.21-5.el5_4.1 set to be updated
    ---> Package yum-metadata-parser.i386 0:1.1.2-3.el5.centos set to be updated
    ---> Package cpio.i386 0:2.6-23.el5 set to be updated
    ---> Package vim-minimal.i386 2:7.0.109-6.el5 set to be updated
    ---> Package libselinux-utils.i386 0:1.33.4-5.5.el5 set to be updated
    ---> Package openssh-clients.i386 0:4.3p2-36.el5_4.2 set to be updated
    ---> Package iproute.i386 0:2.6.18-10.el5 set to be updated
    ---> Package bind-libs.i386 30:9.3.6-4.P1.el5 set to be updated
    ---> Package httpd.i386 0:2.2.3-31.el5.centos.2 set to be updated
    ---> Package tzdata.noarch 0:2009o-2.el5 set to be updated
    ---> Package openssh-server.i386 0:4.3p2-36.el5_4.2 set to be updated
    ---> Package m2crypto.i386 0:0.16-6.el5.6 set to be updated
    ---> Package wget.i386 0:1.11.4-2.el5_4.1 set to be updated
    ---> Package e2fsprogs.i386 0:1.39-23.el5 set to be updated
    ---> Package less.i386 0:394-6.el5 set to be updated
    ---> Package libgcrypt.i386 0:1.4.4-5.el5 set to be updated
    ---> Package iptables.i386 0:1.3.5-5.3.el5_4.1 set to be updated
    ---> Package tcsh.i386 0:6.14-14.el5_4.2 set to be updated
    ---> Package nspr.i386 0:4.7.6-1.el5_4 set to be updated
    ---> Package fipscheck-lib.i386 0:1.2.0-1.el5 set to be updated
    --> Processing Dependency: /usr/bin/fipscheck for package: fipscheck-lib
    ---> Package audit-libs.i386 0:1.7.13-2.el5 set to be updated
    ---> Package tcp_wrappers.i386 0:7.6-40.7.el5 set to be updated
    ---> Package cpp.i386 0:4.1.2-46.el5_4.1 set to be updated
    ---> Package libsepol.i386 0:1.15.2-2.el5 set to be updated
    ---> Package libgcc.i386 0:4.1.2-46.el5_4.1 set to be updated
    ---> Package setup.noarch 0:2.5.58-7.el5 set to be updated
    ---> Package python.i386 0:2.4.3-27.el5 set to be updated
    ---> Package krb5-libs.i386 0:1.6.1-36.el5 set to be updated
    ---> Package grep.i386 0:2.5.1-55.el5 set to be updated
    ---> Package bind.i386 30:9.3.6-4.P1.el5 set to be updated
    ---> Package coreutils.i386 0:5.97-23.el5_4.1 set to be updated
    ---> Package neon.i386 0:0.25.5-10.el5_4.1 set to be updated
    ---> Package postgresql-libs.i386 0:8.1.18-2.el5_4.1 set to be updated
    ---> Package libuser.i386 0:0.54.7-2.1.el5_4.1 set to be updated
    ---> Package centos-release.i386 10:5-4.el5.centos.1 set to be updated
    ---> Package cyrus-sasl.i386 0:2.1.22-5.el5 set to be updated
    ---> Package yum.noarch 0:3.2.22-20.el5.centos set to be updated
    ---> Package sudo.i386 0:1.6.9p17-5.el5 set to be updated
    ---> Package libX11.i386 0:1.0.3-11.el5 set to be updated
    ---> Package rpm.i386 0:4.4.2.3-18.el5 set to be updated
    ---> Package newt.i386 0:0.52.2-12.el5_4.1 set to be updated
    ---> Package gcc.i386 0:4.1.2-46.el5_4.1 set to be updated
    ---> Package mod_ssl.i386 1:2.2.3-31.el5.centos.2 set to be updated
    ---> Package centos-release-notes.i386 0:5.4-4 set to be updated
    --> Running transaction check
    ---> Package mkinitrd.i386 0:5.1.19.6-54 set to be updated
    --> Processing Dependency: nash = 5.1.19.6-54 for package: mkinitrd
    --> Processing Dependency: kpartx >= 0.4.7-9 for package: mkinitrd
    --> Processing Dependency: device-mapper-multipath >= 0.4.7-9 for package: mkinitrd
    --> Processing Dependency: hmaccalc for package: mkinitrd
    --> Processing Dependency: lvm2 for package: mkinitrd
    --> Processing Dependency: dmraid for package: mkinitrd
    ---> Package which.i386 0:2.16-7 set to be updated
    ---> Package fuse.i386 0:2.7.4-8.el5 set to be updated
    --> Processing Dependency: kernel >= 2.6.14 for package: fuse
    ---> Package fipscheck.i386 0:1.2.0-1.el5 set to be updated
    --> Running transaction check
    ---> Package device-mapper-multipath.i386 0:0.4.7-30.el5_4.2 set to be updated
    --> Processing Dependency: libsysfs.so.2 for package: device-mapper-multipath
    ---> Package kpartx.i386 0:0.4.7-30.el5_4.2 set to be updated
    ---> Package lvm2.i386 0:2.02.46-8.el5_4.2 set to be updated
    --> Processing Dependency: device-mapper-event for package: lvm2
    ---> Package fuse.i386 0:2.7.4-8.el5 set to be updated
    --> Processing Dependency: kernel >= 2.6.14 for package: fuse
    ---> Package nash.i386 0:5.1.19.6-54 set to be updated
    ---> Package dmraid.i386 0:1.0.0.rc13-53.el5 set to be updated
    --> Processing Dependency: dmraid-events for package: dmraid
    ---> Package hmaccalc.i386 0:0.9.6-1.el5 set to be updated
    --> Running transaction check
    ---> Package libsysfs.i386 0:2.0.0-6 set to be updated
    ---> Package fuse.i386 0:2.7.4-8.el5 set to be updated
    --> Processing Dependency: kernel >= 2.6.14 for package: fuse
    ---> Package dmraid-events.i386 0:1.0.0.rc13-53.el5 set to be updated
    --> Processing Dependency: sgpio for package: dmraid-events
    ---> Package device-mapper-event.i386 0:1.02.32-1.el5 set to be updated
    --> Running transaction check
    ---> Package fuse.i386 0:2.7.4-8.el5 set to be updated
    --> Processing Dependency: kernel >= 2.6.14 for package: fuse
    ---> Package sgpio.i386 0:1.2.0_10-2.el5 set to be updated
    --> Finished Dependency Resolution
    fuse-2.7.4-8.el5.i386 from base has depsolving problems
    --> Missing Dependency: kernel >= 2.6.14 is needed by package fuse-2.7.4-8.el5.i386 (base)
    Error: Missing Dependency: kernel >= 2.6.14 is needed by package fuse-2.7.4-8.el5.i386 (base)



    > yum clean metadata
    Loaded plugins: fastestmirror
    12 metadata files removed
    8 sqlite files removed
    0 metadata files removed
    > yum update kernel
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Excluding Packages in global exclude list
    Finished
    Setting up Update Process
    No Packages marked for Update
    > yum update kernel
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Excluding Packages in global exclude list
    Finished
    Setting up Update Process
    No Packages marked for Update

  2. #2
    Join Date
    Jul 2009
    Location
    New York
    Posts
    465

    Default

    hi. i updated successfully. it appears you may have failed to read the complete instructions to install. Here they are.

    yum clean all
    yum update glibc\*
    yum update yum\* rpm\* python\*
    yum clean all
    yum update
    shutdown -r now
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •