Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: cant login with ssh

  1. #11
    Join Date
    Nov 2010
    Posts
    1

    Default

    please help!
    I can not login via ssh using root password.
    I can login as user 'alekseybo' using my password for control panel. I have regenerated my root password using control panel, but i can not login as root. I've got such error:
    -----
    root@209.59.219.238's password:
    debug1: Authentications that can continue: publickey,password
    Permission denied, please try again.
    -----
    So I can not use 'sudo' command and also can not install any programms.
    What should I do?


    UPD.

    As support answered:
    The reason 'root' does not work with most of our vps templates is because root ssh logins are disabled by default. You have to login with your other user 'alekseybo' then 'su' to root. As a courtesy I have had SSH access for 'root' enabled. You can now login as root. You will need to regenerate the root password first. If you want to disable SSH access for root again you will need to modify the file '/etc/ssh/sshd_config'. In there you will find the 'PermitRootLogin' option.
    Last edited by mike_britt; 11-24-2010 at 01:17 PM.

  2. #12
    Join Date
    Jul 2009
    Location
    New York
    Posts
    464

    Default

    thank you for posting an update. Was this detail listed in the welcome email?

    I don't believe it's an usual practice to deny root for vps providers though.
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •