Results 1 to 2 of 2

Thread: Is it safe to update all packages on CentOS 5.4 ?

  1. #1

    Default Is it safe to update all packages on CentOS 5.4 ?

    Hi,

    I can see "yum update" reports a lot of packages that need to be updated on CentOS 5.4 (Final). Is it safe to update all on VPS Host ?

    I am most worried about kernel changes:


    Installing:
    kernel i686 2.6.18-194.26.1.el5 updates 17 M

    Removing:
    kernel i686 2.6.18-164.6.1.el5 installed 41 M


    "uname -r" says my kernel is "2.6.18-128.7.1.el5xen". Does VPS has it own kernel for XEN domU ?


    Thanks,
    Paulo Fernando

  2. #2
    Join Date
    Jul 2009
    Location
    New York
    Posts
    465

    Default

    If you are on 5.4 than it should be safe to yum upgrade to 5.5.

    Kernel updates will install with an error as you can't update the xen kernel like that with vpslink. If you install the new xen headers it will cause problems with compiling kernel specific modules since it will be a different version of vpslink's xen kernel. You can exclude it in yum config.

    For whatever reason you restart and it will not boot up, it may need a file check from a support representative which of course will cause some downtime. Calling in should provide the quickest resolution.

    I am on the latest centos so I would say it should be safe. Make sure you are not on centos 5.3 as the upgrade instructions are different.
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •