Results 1 to 6 of 6

Thread: "reset" an apt-get upgrade

  1. #1
    Join Date
    May 2010
    Location
    Turin, Italy
    Posts
    5

    Default "reset" an apt-get upgrade

    Ok, I did the same old error: an apt-get upgrade.

    No permanent damages to the installed system thanks to locks on installed kernel, but now everytime I try to ask something to apt (e.g. install something new) it replies:

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      libc6: Depends: libc-bin (= 2.11.2-2) but 2.13-10 is to be installed
      locales: Depends: glibc-2.13-1
      locales-all: Depends: glibc-2.13-1
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    Of course apt-get -f install doesn't works, it asks me to force installation of another kernel...

    Any suggestion to "reset" the upgrade request, so apt could ignore that dependency problem and unlock the situation?

    Thanks :-)

  2. #2
    Join Date
    Jul 2009
    Location
    New York
    Posts
    465

    Default

    have you tried running aptitude?
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

  3. #3
    Join Date
    May 2010
    Location
    Turin, Italy
    Posts
    5

    Default

    Quote Originally Posted by Cwewmpz View Post
    have you tried running aptitude?
    With which command?

    aptitude -f install cannot resolve the dependency hell.
    aptitude safe-upgrade blocks on the same problem.

  4. #4
    Join Date
    Jul 2009
    Location
    New York
    Posts
    465

    Default

    hrm...

    1.)can you please state your vpslink link package.

    2) openvz or xen

    3) what debian template image you are using and whether it is new or old.

    If this is debian 6 this seems to be a problem with openvz and needs you to open a ticket.
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

  5. #5
    Join Date
    May 2010
    Location
    Turin, Italy
    Posts
    5

    Default

    Quote Originally Posted by Cwewmpz View Post
    hrm...

    1.)can you please state your vpslink link package.

    2) openvz or xen

    3) what debian template image you are using and whether it is new or old.
    Xen, Debian 4.0-i386-default with "stable" and "testing" repositories in sources.list.

    It is not important for me to actually "upgrade" it, I'd just like to abort the attempt to upgrade libc and be able to continue to install needed packages :-\

  6. #6
    Join Date
    Jul 2009
    Location
    New York
    Posts
    465

    Default

    you are still in debian 4? what are your sources.list?

    I have to be honest and say I am unsure about your situation.as etch security updates has been discontinued for over a year. This seems like a question you need to ask in the debian mailing list...
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •