Results 1 to 2 of 2

Thread: Help VPN pptp (no network access)

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Dec 2011

    Default Help VPN pptp (no network access)

    # Solved =D

    Hi everyone,
    I'm fairly new to this and I’m not sure what I’m doing wrong or left out. Anyway here's what I did in order to setup my pptp vpn on ubuntu.

    1. apt-get install pptpd
    2. vi /etc/pptpd.conf
    changed localip to my server's eth0 ip and remoteip to, and uncommented both lines
    3. vi /etc/ppp/chap-secret
    Added username server and password and ip as *
    4. vi /etc/sysctl.conf
    made sure net.ipv4.ip_forward=1 and uncommented it.
    5. vi /etc/ppp/options
    modify and uncommented lines ms-dns, changed it to "ms-dns" and "ms-dns" (google's free DNS)
    6. /etc/init.d/pptpd restart
    7. iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    8. reboot

    through windows 7 vpn network setup I’ve manage to connect and login to my created vpn the only thing is that windows is saying that there is no internet access from my vpn's side.

    Thanks =D

    Edit :

    Ok, I solved my issue which is bascally step 8.
    When i rebooted the server, step 7 iptables routing do not save therefore after every reboot i'll have to re-enter that line in root/shh.

    I'm wondering is there a way to permernantly keep the masquerade routing in effect even after a server restart? Thanks!
    Last edited by nepkerl; 12-16-2011 at 06:22 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts