Results 1 to 9 of 9

Thread: pear command line not working

  1. #1

    Default pear command line not working

    I am setting up a Ubuntu (the problem also happens on Debian Squeeze) Virtual Private Server. I have installed php5 and php-pear. When I go to install a pear package from the command, or if I attempt to upgrade packages, for example
    Code:
    # sudo pear upgrade-all
    pear always gets a "could not download" message. The command above gave:

    Could not download from "http://pear.php.net/get/Structures_Graph-1.0.4.tgz", cannot download "pear/structures_graph" (File http://pear.php.net:80/get/Structures_Graph-1.0.4.tgz not valid (redirected but no location)) Error: cannot download "pear/Structures_Graph"
    I tried purge php-pear and reinstalling. I tried Debian instead of Ubuntu, but got the same message.

  2. #2
    Join Date
    Jul 2009
    Location
    New York
    Posts
    464

    Default

    is this on vpslink? dunno what to tell you but that error message is telling you that it can't download the file. maybe the respository is having issues or you somehow blocking the download ip of that file.

    either try again or check your firewall.
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

  3. #3

    Default

    No, this is not on vpslink. There is no firewall. I think it had something to do with the OS template they used because I tried a different hoster and didn't have the problem.

  4. #4
    Join Date
    Jul 2009
    Location
    New York
    Posts
    464

    Default

    then you have a dns name server problem. change your name servers to google or something.

    that error message is pretty clear and i can download that file from my connection so I have no other suggestions at this time.
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

  5. #5

    Default

    What makes you think it is a name server problem? I don't even have an A record setup for the IP. I'm connecting via SSH using the IP address.

  6. #6
    Join Date
    Jul 2009
    Location
    New York
    Posts
    464

    Default

    ?.

    /etc/resolv.conf
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

  7. #7

    Default

    Code:
    # cat /etc/resolv.conf
    
    nameserver 199.127.224.3

  8. #8
    Join Date
    Jul 2009
    Location
    New York
    Posts
    464

    Default

    i'm sorry are you trolling? i've helped all i can but if you are unwilling to change your resolv.conf to one of the public nameservers than you are just wasting my time.
    Happily on a Link3. Feel free to request a refferal code that takes a 10% lifetime discount off your hosting.
    Please open a SUPPORT TICKET AND CALL vpslink to resolve your vpslink problems FIRST
    I am a CUSTOMER Only. Any vpslink issues should be directed to Matt@VPSLink and/or Michael@VPSLink

  9. #9

    Default

    Sorry, I should have mentioned it's not a vpslink account.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •