Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Gentoo, GCC 4.1.1, and VPSLink2

  1. #11

    Default

    Quote Originally Posted by scotty
    Just wasted my evening trying to figure it out. Oh well...
    I hate it when that happens. I've compiled 5.1.5 without any problems on a VPSLink2 (I think even without distcc, just using limits). By your description, it sounds like the 4.x codebase is possibly compiled differently. Either way, sorry you didn't have such luck.
    Kelvin Nicholson
    http://www.helomx.com - Blacklist and availability monitoring built from the ground up for outsourced IT providers.

  2. #12
    Join Date
    Jun 2006
    Location
    Sydney, Australia
    Posts
    97

    Default

    Quote Originally Posted by kelvinn
    I've compiled 5.1.5 without any problems on a VPSLink2.
    Sorry but do you somehow have an unreleased future version of GCC?

    So far I haven't had problem compiling anything on a link3 except gcc. Have to use binary package built at home...

  3. #13

    Default

    Quote Originally Posted by scotty
    Hmm. I am trying to upgrade to GCC 4.1.1

    Yes, GCC 5.1.5 was just released... Ok, I was reading too quickly, thanks for being good humored though, and not flaming me back to the stone age
    Kelvin Nicholson
    http://www.helomx.com - Blacklist and availability monitoring built from the ground up for outsourced IT providers.

  4. #14
    Join Date
    Feb 2006
    Posts
    773

    Default

    Guys,

    Does a new Gentoo image with a new compiler need to be put together? Let us know if we can help!

  5. #15
    Join Date
    Jun 2006
    Location
    Guadalajara, Mexico
    Posts
    541

    Default

    whats the real advantage of 4.x vs the precompiled 3.4.5? i heard the 4.x is still somewhat buggy is it true?
    pablasso.com (spanish)

  6. #16
    Join Date
    Jun 2006
    Location
    Sydney, Australia
    Posts
    97

    Default

    Quote Originally Posted by pablasso
    whats the real advantage of 4.x vs the precompiled 3.4.5? i heard the 4.x is still somewhat buggy is it true?
    Just that 4.1 has been declared "stable" by the Gentoo guys a few days ago. So after portage files got synchronised, and "emerge system" will automatically try to upgrade the site to GCC 4.1.

    Advantage of GCC 4.1? It is supposed to be more "optimised" That's what new version is for, isn't it? But I am not a GCC expert so I have no idea about the details.

    You can put ">=sys-devel/gcc-4" in your /etc/portage/package.mask file to prevent emerge system or emerge world from upgrading your GCC.

    The same goes with glibc-2.4 that has been declared stable over the last few days. glibc-2.4 is NPTL-only, and requires Linux 2.6.9+. As all VZ nodes are on Linux 2.6.8, you need to edit package.mask to prevent portage from upgrading your libraries.

  7. #17
    Join Date
    Jun 2006
    Location
    australia
    Posts
    64

    Default

    Quote Originally Posted by scotty
    glibc-2.4 is NPTL-only, and requires Linux 2.6.9+. As all VZ nodes are on Linux 2.6.8, you need to edit package.mask to prevent portage from upgrading your libraries.
    Really? I've been running glibc-2.4 with nptlonly for over a month now... should I be worried?

  8. #18
    Join Date
    Aug 2006
    Posts
    159

    Default

    Quote Originally Posted by vpslinkdotcom
    Guys,

    Does a new Gentoo image with a new compiler need to be put together? Let us know if we can help!
    Yes, Gentoo 2006.1 was released last week and includes the newly stable GCC 4.1.1 and glibc 2.4, plus NPTL right out of the box.

  9. #19
    Join Date
    Aug 2006
    Posts
    159

    Default

    Quote Originally Posted by scotty
    The same goes with glibc-2.4 that has been declared stable over the last few days. glibc-2.4 is NPTL-only, and requires Linux 2.6.9+. As all VZ nodes are on Linux 2.6.8, you need to edit package.mask to prevent portage from upgrading your libraries.
    This is incorrect. On Gentoo at least, any system using 2.6.x kernel headers will work with NPTL, including 2.6.8 and earlier.

  10. #20
    Join Date
    Jun 2006
    Location
    Sydney, Australia
    Posts
    97

    Default

    Quote Originally Posted by jcsix
    This is incorrect. On Gentoo at least, any system using 2.6.x kernel headers will work with NPTL, including 2.6.8 and earlier.
    Well, that could be a possibility.

    When I tried to emerge glibc-2.4 a warning message printed out saying NPTL-only requires kernel >= 2.6.9.

    From glibc-2.4-r3.ebuild:

    Code:
    # (Recent snapshots fails with 2.6.5 and earlier with NPTL)
    NPTL_KERNEL_VERSION=${NPTL_KERNEL_VERSION:-"2.6.9"}
    ...
    ebegin "Checking kernel version (>=${NPTL_KERNEL_VERSION})"
    if ! eend $([[ $(get_KV) -ge ${min_kernel_version} ]]) ; then
        echo
        eerror "You need a kernel of at least version ${NPTL_KERNEL_VERSION}"
        eerror "for NPTL support!"
        die "Kernel version too low!"
    fi
    Great if it works for you

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •