Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: What is nash-hotplug and why is it consuming 100% CPU?

  1. #1

    Unhappy What is nash-hotplug and why is it consuming 100% CPU?

    I just killed nash-hotplug on all of my VPS's, because I noticed it was keeping the load at 1.00 and just chewing up all the CPU for itself. I'm assuming this is part of the VPS stuff, because there is no such binary on my system, and I also see that the init is using /sbin/nash, which also doesn't exist.

    Should the VPS's be configured to support hotplugging (in a server environment I really don't see a need for this)? Has anybody ran into this problem before?

  2. #2

    Default

    I've never heard of it or seen it myself, but a google search returns this blog http://www.darkrune.org/blog/?p=154, which describes how to disable it at boot (basically it's a start-up script hack). Dunno why you're getting it though.. very odd.
    Last edited by Tikus; 01-12-2008 at 08:57 PM. Reason: Quick Fix

  3. #3

    Default

    I would most likely file a support ticket with VPSLink to at least alert them of the issue. Does anything even come up if you do a locate for 'nash'?
    Kelvin Nicholson
    http://www.helomx.com - Blacklist and availability monitoring built from the ground up for outsourced IT providers.

  4. #4

    Default

    Quote Originally Posted by kelvinn View Post
    I would most likely file a support ticket with VPSLink to at least alert them of the issue. Does anything even come up if you do a locate for 'nash'?
    No, I don't waste I/O with updatedb...only on demand...

    find / -name 'nash*'
    ...returns nothing though...
    Casey Allen Shobe
    Open Source Software Solutions

  5. #5

    Default

    Quote Originally Posted by Casey|OSSS.net View Post
    No, I don't waste I/O with updatedb...only on demand...
    The perfect neighbour.
    Kelvin Nicholson
    http://www.helomx.com - Blacklist and availability monitoring built from the ground up for outsourced IT providers.

  6. #6
    Join Date
    Feb 2006
    Posts
    773

    Default

    Casey,

    Nash should be disabled. We generally just put 'pkill -9 nash' in /etc/rc.local. Can you tell me what distro you found this issue on?

    Thanks!

  7. #7

    Default

    Quote Originally Posted by vpslinkdotcom View Post
    Casey,

    Nash should be disabled. We generally just put 'pkill -9 nash' in /etc/rc.local. Can you tell me what distro you found this issue on?

    Thanks!
    Gentoo/Xen. Great minds think alike - I had put killall nash-hotplug in /etc/conf.d/local.start after initially posting this.
    Casey Allen Shobe
    Open Source Software Solutions

  8. #8
    Join Date
    Apr 2008
    Posts
    2

    Default Also in debian-4.0-i386-default

    I found this issue today in the debian-4.0-i386-default/xen image as well. I wonder how many cycles are being chewed up by this.

    Jim

  9. #9
    Join Date
    Jan 2006
    Posts
    127

    Default

    Hello,

    Yes, it appears our latest published Xen templates have this issue again. Our template developers are investigating and repairing now.

  10. #10
    Join Date
    Oct 2007
    Posts
    7

    Default

    Hi,

    I have just installed the openSUSE 11/Xen template and it seems to have this issue as well.

    Cheers,
    Shane

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •