Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Much Arch usage?

  1. #11
    Join Date
    Nov 2008
    Posts
    2

    Default

    after reading over the arch forum, i grabbed coreutils and downgraded, error is gone. will have to avoid "pacman -Syu"

  2. #12

    Default

    I know this thread is a bit old, but incase anyone new to arch is reading this, I just wanted to comment on avoiding -Syu.

    Avoiding upgrades in Arch is a bad idea. This is because of the rolling-release nature of the distro. Neglecting to upgrade a rolling-release distro, on a frequent basis, will expose the system to security vulnerabilities in packages.

    Some distros patch security issues when they pop up, so that you can continue to use the same version of a package, except with the security issue fixed. This is not the case on a rolling-release distro, and the only way to maintain security is to upgrade. If savy enough, this can be done on a per-package basis instead of a systemwide upgrade. But you would have to monitor every single package on your system for security issues for this to workout.

    If part of coreutils is the problem here, I think the better solution would be to enter a line in your pacman.conf to avoid upgrades of _only_ coreutils. Or better yet, upgrade coreutils to the latest version that works, copy-out the program thats causing the trouble(`touch`), and upgrade the coreutils package too.

  3. #13
    Join Date
    Oct 2010
    Posts
    1

    Default

    Quote Originally Posted by DanL@VPSLink View Post
    There is no additional cost for the Arch Linux template under OpenVZ, however, you would need to cancel your account and create a new account at VPSLink if you are migrating from the Xen platform. (As described in the ] thread)
    I've just set up Arch on a Link-2. I've been using yaourt without any problems, but I haven't compiled much.

    If you need to compile something on a Link-1, distcc may be your only option.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •