Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Qmail POP3 port 110 connection refused

  1. #1

    Unhappy Qmail POP3 port 110 connection refused

    Hello,
    since yesterday i cannot connect to qmail at port 110.
    Previously it worked with no problem.

    I tried:
    telnet www.mydomain.com 110

    it resolves the domain correctly but it says:
    telnet: connect to address xx.xx.xx.xx: Connection refused

    webmail and IMAP work correctly.

    Any ideas?

    Thank you very much!ian

  2. #2

    Default

    update...
    I tryed to restart the server but the server didn't shutdown from VPSlink control panel. So I opened a ticket and they restarted my VPS manually and now I can connect to port 110.

    So, problem solved... I hope.

    Thank you anyway!ian

  3. #3

    Default

    Hello,
    the former problem happened again.
    I restarted qmail but the problem persisted.
    Only if I restart the VPS the problem disappears.

    Please, have you any tips on how to debug this problem?

    Thank you in advance.
    ian

  4. #4
    Join Date
    Dec 2007
    Posts
    1,141

    Default

    The best place to start will be your beancounter* and log files - you need to determine whether the issue is related to qmail's memory usage and, if qmail is operating within your VPS memory allocation, what is happening when the process dies.

    * The /proc/user_beancounters file will only be available on the OpenVZ and Virtuozzo VPS platforms. Xen VPS administrators may access similar information through top, however, the failcnt troubleshooting step will not apply.

    Run cat /proc/user_beancounters and check the failcnt column - if you notice any failcnt values, there is a good chance that qmail is being killed for pushing your VPS over its memory allocation limit.

    Please see the Meaning of the beancounters values wiki entry for more information on the beancounters rows.

    If you have determined that qmail is not being killed as a result of its memory usage, this qmail log file tutorial provides a good basis for locating your log files and interpreting their contents.

    It is possible that your qmail log files will not contain useful information which will allow you to troubleshoot the issue at hand. If this is the case, you may want to review what is happening to qmail as it runs.


    Use strace to log the activity of a process:

    1) Download and install strace


    2) Begin stack trace logging for qmail and its child processes with nohup strace -f -p `pgrep qmail` 2>&1 | tail -1000 > ~/qmail-strace.log


    3) Post the log entries preceding the incident for review

  5. #5

    Default

    Thank you very much DanL for your answer.

    With cat /proc/user_beancounters I have sometimes some failcnt in privvmpages.

    If I run nohup strace -f -p 'pgrep qmail' 2>&1 | tail -1000 > ~/qmail-strace.log I have this output:

    strace: Invalid process id: pgrep qmail

    but if I run pgrep qmail I have the processes IDs.

    By the way, If is qmail that caused the connection refused on port 110 (IMAP and SMTP both work), why qmail doesn't get back to work when I restart it?

    Can't be that it's another process that causes the connection refused in POP3?

    Thanks!ian

  6. #6
    Join Date
    Feb 2007
    Posts
    117

    Default

    You used the ' instead of the ` around the pgrep qmail, try cutting and pasting from the previous post if you don't know which keys I'm talking about.

    AFAIK qmail only handles SMTP, you should be looking at something else if your problem is related to POP.
    intelligence is a tool to be used toward a goal, and goals are not always chosen intelligently
    Larry Niven, Protector

  7. #7

    Default

    Thank you SteveM,
    I used ' instead of the ` because, when I copy and paste, that char disappeared using Bitvise Xterm as shell program.
    I tryed again using Putty and it pastes the char correctly.

    Now, after 30 minutes, strace is still running. Is it normal?

    Btw, SteveM you're right. The POP3 connection is managed by courier-imap not Qmail.

    Now I figured out who caused the problem. I set a daily backup with LXAdmin. Everytime the backup starts, it kills courier-imap (not SSL) processes. I don't know why at the moment, but i'm still investigating. I asked LXLabs about this and they suggest me to upgrade to Centos 5. But I really would like to avoid this upgrade at the moment.

    A quick dirty solution could be to make a cron to restart courier-imap after the backup. I did it adding this line to crontab:
    00 5 * * * service courier-imap restart

    but it doesn't work. It doesn't restart courier-imap even if in the Cron log I find:
    Feb 24 05:00:03 myservername crond[28195]: (root) CMD (service courier-imap restart)

    If I give the command "service courier-imap restart" manually, it works.

    Where I am wrong?

    Thanks!ian

  8. #8
    Join Date
    Feb 2007
    Posts
    314

    Default

    Yes do not try to upgrade unless lxhelp is willing to help you as there will be many issues. You are better off to start with a fresh install of centos5 and then install lxadmin through the command line.

    AS for your mail problem, I bet it's a resource issue. What package are you on here?

  9. #9

    Default

    Hi R1Lover,
    I have Link-4.

    Bye!ian

  10. #10
    Join Date
    Feb 2007
    Posts
    314

    Default

    Then you should not have any resource issues, I run lxadmin on a couple of link4 packages with no issues.

    Have you updated lxadmin to the latest version?

    if not run this

    /script/upcp

    then try again... you can even run yum update to update the rest of the os, but watch out for the udev issue.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •