Results 1 to 3 of 3

Thread: SSL Problem

  1. #1

    Question SSL Problem

    Sorry, if I placed this in the wrong location, but I'm having difficulties getting vsftp to work.

    Briefly, I followed instructions, at this site, and they told me that, after creating a file via:



    "openssl req -x509 -nodes -days 365 -newkey rsa:1024 \
    -keyout /etc/vsftpd/vsftpd.pem \
    -out /etc/vsftpd/vsftpd.pem"



    ...I had to add some lines to vsftpd.conf and then restart restart vsftpd.



    Those lines were:



    "ssl_enable=YES
    allow_anon_ssl=NO
    force_local_data_ssl=NO
    force_local_logins_ssl=NO
    ssl_tlsv1=YES
    ssl_sslv2=NO
    ssl_sslv3=NO
    rsa_cert_file=/etc/vsftpd/vsftpd.pem"



    Yet, when restarting vsftp, I got the following message:



    "/etc/rc.d/init.d/vsftpd restart
    Shutting down vsftpd: [ OK ]
    Starting vsftpd for vsftpd: 500 OOPS: unrecognised variable in config file: allow_anon_ssl
    [FAILED]"



    Moreover, I found out, through trial & error, that 'restart' had a similar problem with every line below: ssl_enable=YES.

    Further, when I placed "#" in front of each of those 'problem' lines, I got this message:



    "Starting vsftpd for vsftpd: 500 OOPS: SSL: cannot load RSA certificate
    [FAILED]"



    Yet, when I removed the "#" from the front of that last line, the message changed to:



    "Starting vsftpd for vsftpd: 500 OOPS: unrecognised variable in config file: rsa_cert_file
    [FAILED]"



    Any thoughts on how to resolve this?

    - j

  2. #2

    Default

    Solved!

    - j

  3. #3
    Join Date
    Oct 2010
    Posts
    1

    Default What is the solution

    Post deleted
    Last edited by Neil Parks; 10-20-2010 at 07:27 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •