Results 1 to 6 of 6

Thread: Processes using almost 100% cpu

  1. #1

    Default Processes using almost 100% cpu

    Ok, this isn't a normal process to be eating CPU, but it is. I've attached the top command results, and would love to know why this process is eating so much CPU. If I restart the VPS, the Top command results look awesome, everything's where it should be. but after about a day or so, it gets this way. Any suggestions?

    Code:
    [root@mitternacht ~]# top
    top - 08:31:46 up 1 day, 20:10,  1 user,  load average: 3.90, 3.65, 3.44
    Tasks:  34 total,   3 running,  31 sleeping,   0 stopped,   0 zombie
    Cpu(s):  9.1%us, 44.7%sy,  0.0%ni, 46.2%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:   1024000k total,   235636k used,   788364k free,        0k buffers
    Swap:        0k total,        0k used,        0k free,        0k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
    21622 root      18   0  2296 1000  808 R 26.1  0.1   0:02.00 top
    22013 root      19   0  1732  548  488 S 26.1  0.1   0:02.00 mingetty
    21755 root      20   0  1732  548  488 S 25.8  0.1   0:01.98 mingetty
    21530 root      20   0  1728  544  488 S 19.4  0.1   0:01.98 mingetty
    23762 root      19   0  1732  352  300 R 17.6  0.0   0:01.35 mingetty
    23944 root      19   0  1732  352  300 R 16.1  0.0   0:01.23 mingetty
    20306 root      18   0  1736  552  488 S 14.5  0.1   0:01.93 mingetty
        1 root      15   0  1876  844  632 S  0.0  0.1   0:13.00 init
    13361 root      15  -4  2252  560  348 S  0.0  0.1   0:00.00 udevd
    13952 root      15   0 29004 1052  712 S  0.0  0.1   0:29.19 rsyslogd
    14042 root      15   0  7356 1060  664 S  0.0  0.1   0:08.84 sshd
    14185 root      15   0 23872 6640 3768 S  0.0  0.6   0:00.86 httpd
    14207 root      15   0  3448 1156  604 S  0.0  0.1   0:00.08 crond
     5594 root      19   0  2644 1192 1028 S  0.0  0.1   0:00.00 mysqld_safe
     5680 mysql     15   0  110m  19m 5172 S  0.0  1.9   0:23.79 mysqld
    30043 apache    15   0 29548  10m 4612 S  0.0  1.1   0:05.36 httpd
    30044 apache    15   0 29032  10m 4608 S  0.0  1.0   0:06.72 httpd
    27974 apache    15   0 31216  13m 5284 S  0.0  1.3   0:07.98 httpd
    30473 apache    15   0 29600  10m 4520 S  0.0  1.1   0:04.23 httpd
    14152 apache    15   0 28564 9.8m 4400 S  0.0  1.0   0:04.37 httpd
    23633 apache    15   0 30336  11m 4488 S  0.0  1.2   0:02.06 httpd
     9806 apache    15   0 29500  10m 4356 S  0.0  1.1   0:00.94 httpd
     3333 apache    15   0 29528  10m 4480 S  0.0  1.1   0:01.08 httpd
     3559 apache    15   0 29016  10m 4652 S  0.0  1.0   0:01.69 httpd
    28545 apache    15   0 29504  10m 4524 S  0.0  1.1   0:01.34 httpd
    19844 apache    15   0 30304  11m 3932 S  0.0  1.1   0:02.43 httpd
    20058 apache    15   0 29532  10m 4592 S  0.0  1.1   0:02.34 httpd
    20059 apache    15   0 29752  10m 3876 S  0.0  1.0   0:00.95 httpd
    20060 apache    15   0 29532  10m 4264 S  0.0  1.1   0:01.09 httpd
    17845 apache    15   0 27248   9m 3852 S  0.0  1.0   0:00.38 httpd
    17798 root      15   0 10252 2908 2364 S  0.0  0.3   0:00.13 sshd
    19900 root      15   0  2656 1444 1184 S  0.0  0.1   0:00.00 bash
    24152 root      16   0  8700 2292 1872 S  0.0  0.2   0:00.00 sshd
    24221 sshd      15   0  8704 1196  768 S  0.0  0.1   0:00.00 sshd

  2. #2

    Default

    I found a workaround, albeit not a good one.

    I found that my utmp file was ~500 MB in size, so I moved it to utmp2, then deleted it. It made a huge performance difference in running "top" and mingetty isn't hogging cpu anymore. Problem is, that file gets to ~500 MB in one day. What would happen if I left this server running forever?

    I may not want to know.

  3. #3
    Join Date
    Dec 2007
    Posts
    1,141

    Default

    mingetty is used to support console login activity and there is no "console" to log in from in a VPS environment.

    You can comment out any references to mingetty in your /etc/inittab file to disable the daemon - this should prevent mingetty from logging to the utmp file and consuming CPU time.

  4. #4

    Default

    K, I did that, and some other things, and it works well.


  5. #5
    Join Date
    Mar 2009
    Posts
    2

    Default

    I am having the same problem, except there is NO reference to mingetty in /etc/inittab. I am running Fedora 9. Any suggestions how I can disable mingetty?

  6. #6
    Join Date
    Dec 2007
    Posts
    1,141

    Default

    You can forcibly disable mingetty by moving the executable to a new location:

    Code:
    mv /sbin/mingetty /sbin/mingetty.OFF

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •