Results 1 to 5 of 5

Thread: mod_rewrite problems on OpenSuSE 11

  1. #1
    Join Date
    Jan 2009
    Posts
    7

    Default mod_rewrite problems on OpenSuSE 11

    I've just finished setting up a moved WordPress blog from elsewhere to VPSLink.

    I'm having problems with mod_rewrite urls. I get 404's for them.

    I have mod_rewrite and mod_headers set up, according to my phpinfo() run I did (<?php phpinfo(); ?>) in blah.php.

    Here's my .htaccess for the wordpress directory (written by the application):
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    I have rewrite and headers in the APACHE_HEADERS entry in /etc/sysconfig/apache2.

    Also - I did a fresh install of the software (I nuked the database and the wordpress directory [including .htaccess, yes] and subdirectories) and got the same problem.

    I think I don't have something set up correctly on the OS side.

    Any hints would be appreciated -
    Brian

  2. #2
    Join Date
    Mar 2008
    Posts
    142

    Default

    check the vhost for your site, what's AllowOverride set to?

  3. #3
    Join Date
    Jan 2009
    Posts
    7

    Default

    I'm not using vhost - I'm using httpd.conf. Here's a snippet:

    <Directory />
    Options None
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # use .htaccess files for overriding,
    AccessFileName .htaccess
    # and never show them
    <Files ~ "^\.ht">
    Order allow,deny
    Allow from all
    </Files>

    Thanks -
    Brian

  4. #4
    Join Date
    Mar 2008
    Posts
    142

    Default

    what's the 'ls' of /etc/apache2/site-enabled/

    or if you don't have that dir it's equiv.

    You've tried restarting the server right?

  5. #5
    Join Date
    Jan 2009
    Posts
    7

    Default thanks for your aid and assistance

    I've got it going now - pretty rewritten URLs instead of ugly ones.

    Thanks for your aid and assistance - ended up adding Rewrite stuff to httpd.conf (after I changed OS's and installed cpanel - long story).

    Brian

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •