Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Problem with MySQL after Fedora LAMP Install

  1. #1
    Join Date
    Nov 2006
    Posts
    4

    Default Problem with MySQL after Fedora LAMP Install

    After upgrading to VPS 3, I chose the Fedora LAMP install, after the installation everything looks good, except when I try to run MySQL in any way, I get:

    Code:
    [root@rudedwarf mysql]# mysql -u root
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    And when I go to /var/lib/mysql/ there isnt anything there....

    You can check out my phpinfo file here, if that helps:

    www.eternalheroes.org/info.php

    Thanks for any help you can give!

  2. #2
    Join Date
    Jun 2006
    Location
    Guadalajara, Mexico
    Posts
    541

    Default

    i don't know about those default installations but maybe it just didn't created the mysql table, try to start it with '/etc/init.d/mysql start' and then follow the instructions when it complains
    pablasso.com (spanish)

  3. #3
    Join Date
    Oct 2006
    Posts
    21

    Default

    what shows in your mysql error log?

    tail -f /var/lib/mysql/.... .er ??

  4. #4
    Join Date
    Nov 2006
    Posts
    4

    Default

    Quote Originally Posted by freevps
    what shows in your mysql error log?

    tail -f /var/lib/mysql/.... .er ??

    the folder is empty...there is no log file there
    Last edited by nate; 11-03-2006 at 04:20 PM.

  5. #5
    Join Date
    Nov 2006
    Posts
    4

    Default

    Quote Originally Posted by pablasso
    i don't know about those default installations but maybe it just didn't created the mysql table, try to start it with '/etc/init.d/mysql start' and then follow the instructions when it complains

    awesome, i got it:

    [root@rudedwarf init.d]# ./mysqld start

    that did it!

    thanks guys for the help, much appreciated

  6. #6
    Join Date
    Aug 2006
    Posts
    1,019

    Default

    Try the following:

    ---------------------
    # DEBUG=10
    # export DEBUG
    # /etc/init.d/mysql start
    ---------------------

    Post back the response if what it gives you isn't obvious.

  7. #7
    Join Date
    Aug 2006
    Posts
    1,019

    Default

    Quote Originally Posted by nate
    [root@rudedwarf init.d]# ./mysqld start
    mysqld instead of mysql within the /etc/init.d directory? Hmm. Something seems odd about that. Oh well, as long as it works.

  8. #8
    Join Date
    Oct 2006
    Posts
    29

    Default

    I think that the Fedora LAMP install doesn't have mysql turned on by default. You can check this by typing chkconfig --list on the command line. Look for the line that lists mysql to see if its turned on. If you want to have it turn on automatically you can enter chkconfig --level <level> mysqld on. Substituting <level> with the appropriate runlevel for your server.

  9. #9
    Join Date
    Nov 2008
    Posts
    17

    Default

    This would have been helpful info for me - I just got Fedora LAMP installed on my OpenVZ server, and I get the same message OP got - but chkconfig does not exist.

  10. #10
    Join Date
    Jun 2008
    Location
    California
    Posts
    338

    Default

    Quote Originally Posted by factorial View Post
    This would have been helpful info for me - I just got Fedora LAMP installed on my OpenVZ server, and I get the same message OP got - but chkconfig does not exist.
    Are you logged in as root?
    Try using the full path: /sbin/chkconfig

    Otherwise install it with yum
    Code:
    yum install chkconfig
    Note: my views are my own and do not reflect those of VPSLink

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •