Results 1 to 6 of 6

Thread: baselayout-vserver is history

  1. #1
    Join Date
    Aug 2006
    Posts
    159

    Default baselayout-vserver is history


  2. #2
    Join Date
    Jun 2006
    Location
    Guadalajara, Mexico
    Posts
    541

    Default

    thanks for the info, that's really tempting o.o
    pablasso.com (spanish)

  3. #3
    Join Date
    Jun 2006
    Location
    australia
    Posts
    64

    Default

    Hey this is great news, thanks for the heads up.

    baselayout-vserver always lagged behind baselayout and it was really annoying since there were bugs in baselayout-vserver a while ago that were already fixed in the normal baselayout. The difference between the two baselayouts were small so I'm really glad they decided to merge them together.

  4. #4

    Default

    OK, so what do I do... I'm trying an update world and I get this:

    gate ~ # emerge -avuDN world

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild N ] sys-apps/baselayout-1.12.11.1 USE="unicode -bootstrap -build -static" 0 kB
    [ebuild N ] sys-apps/module-init-tools-3.5 USE="-old-linux" 0 kB
    [ebuild N ] sys-fs/udev-124-r1 USE="(-selinux)" 0 kB
    [ebuild NS ] sys-kernel/gentoo-sources-2.6.27-r8 [2.6.19-r5, 2.6.22-r5, 2.6.23-r3, 2.6.23-r9, 2.6.24-r8] USE="-build -symlink" 0 kB
    [ebuild U ] net-firewall/iptables-1.4.2-r2 [1.4.0-r1] USE="-l7filter (-extensions%) (-imq%) (-ipv6%*) (-static%)" 0 kB

    Total: 5 packages (1 upgrade, 3 new, 1 in new slot), Size of downloads: 0 kB

    !!! The following installed packages are masked:
    - sys-apps/baselayout-vserver-1.11.14-r4 (masked by: package.mask)
    /usr/portage/profiles/package.mask:
    # mask pending removal
    # Benedikt Böhm <hollow@gentoo.org> (10 Jan 2009)
    # baselayout-vserver is unmaintained and obsoleted by baselayout-2/openrc.
    # Please, upgrade to openrc. removal after openrc goes stable, bug #254519

    For more information, see the MASKED PACKAGES section in the emerge
    man page or refer to the Gentoo Handbook.


    Would you like to merge these packages? [Yes/No]


    Saying Yes just says that there are file collisions with baselayout-vserver-1.11.14-r4.

  5. #5
    matth@vpslink Guest

    Default

    Quote Originally Posted by Giles Coochey View Post
    OK, so what do I do... I'm trying an update world and I get this:

    gate ~ # emerge -avuDN world

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild N ] sys-apps/baselayout-1.12.11.1 USE="unicode -bootstrap -build -static" 0 kB
    [ebuild N ] sys-apps/module-init-tools-3.5 USE="-old-linux" 0 kB
    [ebuild N ] sys-fs/udev-124-r1 USE="(-selinux)" 0 kB
    [ebuild NS ] sys-kernel/gentoo-sources-2.6.27-r8 [2.6.19-r5, 2.6.22-r5, 2.6.23-r3, 2.6.23-r9, 2.6.24-r8] USE="-build -symlink" 0 kB
    [ebuild U ] net-firewall/iptables-1.4.2-r2 [1.4.0-r1] USE="-l7filter (-extensions%) (-imq%) (-ipv6%*) (-static%)" 0 kB

    Total: 5 packages (1 upgrade, 3 new, 1 in new slot), Size of downloads: 0 kB

    !!! The following installed packages are masked:
    - sys-apps/baselayout-vserver-1.11.14-r4 (masked by: package.mask)
    /usr/portage/profiles/package.mask:
    # mask pending removal
    # Benedikt Böhm <hollow@gentoo.org> (10 Jan 2009)
    # baselayout-vserver is unmaintained and obsoleted by baselayout-2/openrc.
    # Please, upgrade to openrc. removal after openrc goes stable, bug #254519

    For more information, see the MASKED PACKAGES section in the emerge
    man page or refer to the Gentoo Handbook.


    Would you like to merge these packages? [Yes/No]


    Saying Yes just says that there are file collisions with baselayout-vserver-1.11.14-r4.
    You are seeing this message because sys-apps/baselayout-vserver is obsoleted by sys-apps/baselayout-2. Simply unmerge sys-apps/baselayout-vserver first and then emerge world.
    Code:
    # emerge -C sys-apps/baselayout-vserver && emerge -avuDN world

  6. #6
    Join Date
    Mar 2009
    Posts
    5

    Default

    The info on this page wiki.vpslink.com/Installing_Gentoo should be fixed to what make.profile references.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •