Results 1 to 2 of 2

Thread: postfix not fetching emails from the net

  1. #1
    Join Date
    Mar 2009
    Posts
    1

    Default postfix not fetching emails from the net

    I have installed postfix and dovecot on my server example.in

    I am able to telnet on both port 25 & 110 from outside and send email & login successfully.

    The only problem is that the sever is not fetching emails from the internet.

    What could possibly be wrong?

    Thanks in anticipation

  2. #2
    Join Date
    Oct 2007
    Location
    UK
    Posts
    129

    Default

    postfix doesn't 'fetch' (or pull) mail from the 'net. Other systems push mail to it. To do that, the other machines must have a way to map a mail domain to a machine name. This is done with DNS MX records.

    My guess is that you have not set up an MX record for your domain, or that there is a existing one that points somewhere else. Try running
    Code:
    dig your.domain.com mx
    from your VPS and check that the name reported is your machine running postfix. Also try an MX lookup using a service like this one, which not only will tell you if you have an MX record, but will help verify that there isn't a problem with DNS propagation.

    Also check that if there are multiple MX records, then all of them point to machines that will eventually deliver to your VPS.
    Charles Haley
    www.haleys.eu/chaley

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •