Results 1 to 2 of 2

Thread: Installing phpMyAdmin - mcrypt problem

  1. #1
    Join Date
    Mar 2009
    Posts
    9

    Default Installing phpMyAdmin - mcrypt problem

    Hey guys,

    I've got a link3 account with the Fedora LAMP stack. I'm trying to get phpMyAdmin running and it's complaining that the mcrypt extension to PHP is not there. I ran yum install, and got a notice that it was already installed and current which I guess means that the particular PHP that came with the stack didn't have the extension built in at compile time. That seems more than a bit weird right at the get-go.

    So then what I figured I'd do is get the package, build PHP WITH mcrypt, and install it unless there's a simple way to patch the existing build to recognize mcrypt, make phpmyadmin happy and get on with my life.

    Anyway, I tried apt-get but that instruction doesn't seem to be available in Fedora.

    Does anyone have a clue how to get phpMyAdmin going in Fedora?

    Thanks in advance,

    Frank

  2. #2
    Join Date
    Jul 2007
    Location
    127.0.0.1
    Posts
    392

    Default

    What's the output of these commands?
    Code:
    [root@host ~]# yum install libmcrypt
    [root@host ~]# yum install php-mcrypt*
    [root@host ~]# yum install php-mhash*
    [root@host ~]# service httpd restart

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •