Results 1 to 2 of 2

Thread: WHM nameserver weirdness - can't create new accounts

  1. #1
    Join Date
    Apr 2009
    Posts
    10

    Question WHM nameserver weirdness - can't create new accounts

    I'm trying to set up a new account in WHM, but account setup fails.
    Anyone have any ideas on how to solve this?

    I'm experiencing a number of problems/symptoms:
    1.Only my secondary nameserver address appears in the 'Add Account' form page.

    2.In 'Server Configuration > Basic CPanel/WHM setup', the field 'Primary Nameserver Setup' displays the correct nameserver, but the HTML that normally displays is missing- in its place is a blank space. Ordinarily, this would read:
    Code:
    Primary Nameserver
    * Enter the hostname of the primary nameserver you wish to use when creating new domains or subdomains.
    
    Assign IP Address  |  Add an A entry for this server
    
    Examples: ns.myhost.com, ns1.myhost.com, dns1.mydomain.com
    3. When I fill out the form and press 'Create', I get the a pop-up window that tells me to 'Setup a nameserver', then a failure message following that reads:

    Code:
     Create a new Account
    Account Creation Status: failed (Please setup a nameserver)
    Please setup a nameserver
    In WHM, under 'Networking setup > Nameserver IPs', the correct IPs and addresses are set for my private nameservers. Likewise, the settings in 'Networking setup > Resolver configuration' are correct (my private nameservers).

    I've checked /etc/nameserverips, and it reads:
    Code:
    111.111.111.111=0
    222.222.222.222=ns1.myprivateserver.example
    333.333.333.333=ns2.myprivateserver.example
    444.444.444.444=0
    I've also checked /etc/wwwacct.conf, it looks correct:
    Code:
    NS1 ns1.myprivateserver.example
    NS2 ns2.myprivateserver.example
    I've also checked /etc/resolv.conf, and it too seems to be correct:
    Code:
    nameserver 222.222.222.222
    nameserver 333.333.333.333
    The zone file for the domain contains A entries for the both nameservers.

    Lastly, here's an anonymised copy of my named.conf file. I can't see anything out of the ordinary in it either.
    Code:
    include "/etc/rndc.key";
    
    controls {
    	inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
    };
    
    options {
        /* make named use port 53 for the source of all queries, to allow
             * firewalls to block all ports except 53:
             */
    
        // query-source    port 53;
    
        /* We no longer enable this by default as the dns posion exploit
            has forced many providers to open up their firewalls a bit */
    
        // Put files that named is allowed to write in the data/ directory:
        directory                "/var/named"; // the default
        pid-file                 "/var/run/named/named.pid";
        dump-file                "data/cache_dump.db";
        statistics-file          "data/named_stats.txt";
       /* memstatistics-file     "data/named_mem_stats.txt"; */
    
    /* OpenDNS forwarders */
    forwarders { 208.67.222.222; 208.67.220.220; };
    
    };
    
    logging {
    /*      If you want to enable debugging, eg. using the 'rndc trace' command,
     *      named will try to write the 'named.run' file in the $directory (/var/named").
     *      By default, SELinux policy does not allow named to modify the /var/named" directory,
     *      so put the default debug log file in data/ :
     */
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
    };
    
    // All BIND 9 zones are in a "view", which allow different zones to be served
    // to different types of client addresses, and for options to be set for groups
    // of zones.
    //
    // By default, if named.conf contains no "view" clauses, all zones are in the
    // "default" view, which matches all clients.
    //
    // If named.conf contains any "view" clause, then all zones MUST be in a view;
    // so it is recommended to start off using views to avoid having to restructure
    // your configuration files in the future.
    
    view "localhost_resolver" {
    /* This view sets up named to be a localhost resolver ( caching only nameserver ).
     * If all you want is a caching-only nameserver, then you need only define this view:
     */
        match-clients         { 127.0.0.0/24; };
        match-destinations    { localhost; };
        recursion yes;
    
        zone "." IN {
            type hint;
            file "/var/named/named.ca";
        };
    
        /* these are zones that contain definitions for all the localhost
         * names and addresses, as recommended in RFC1912 - these names should
         * ONLY be served to localhost clients:
         */
        include "/var/named/named.rfc1912.zones";
    };
    
    view "internal" {
    /* This view will contain zones you want to serve only to "internal" clients
       that connect via your directly attached LAN interfaces - "localnets" .
     */
        match-clients        { localnets; };
        match-destinations    { localnets; };
        recursion yes;
    
        zone "." IN {
            type hint;
            file "/var/named/named.ca";
        };
    
        // include "/var/named/named.rfc1912.zones";
        // you should not serve your rfc1912 names to non-localhost clients.
    
        // These are your "authoritative" internal zones, and would probably
        // also be included in the "localhost_resolver" view above :
    
    zone "exampledomain.com" {
    	type master;
    	file "/var/named/exampledomain.com.db";
    };
    
    zone "exampledomain2.com" {
    	type master;
    	file "/var/named/exampledomain2.com.db";
    };
    
    zone "exampledomain3.com" {
    	type master;
    	file "/var/named/exampledomain3.db";
    };
    
    
    };
    
    view    "external" {
    /* This view will contain zones you want to serve only to "external" clients
     * that have addresses that are not on your directly attached LAN interface subnets:
     */
        recursion no;
        // you'd probably want to deny recursion to external clients, so you don't
        // end up providing free DNS service to all takers
    
        // all views must contain the root hints zone:
        zone "." IN {
            type hint;
            file "/var/named/named.ca";
        };
    
        // These are your "authoritative" external zones, and would probably
        // contain entries for just your web and mail servers:
    
        // BEGIN external zone entries
    
    zone "exampledomain.com" {
    	type master;
    	file "/var/named/exampledomain.com.db";
    };
    
    zone "exampledomain2.com" {
    	type master;
    	file "/var/named/exampledomain2.com.db";
    };
    
    zone "exampledomain3.com" {
    	type master;
    	file "/var/named/exampledomain3.db";
    };
    
    };
    Last edited by blueplanet; 04-07-2009 at 12:34 PM.

  2. #2
    Join Date
    Apr 2009
    Posts
    10

    Default

    Resolved!
    I've changed the "NS1 ns1.myprivateserver.example" line in /etc/wwwacct.conf to "NS ns1.myprivateserver.example" and all the abovementioned symptoms have disappeared. I can now successfully create a www account.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •