Results 1 to 4 of 4

Thread: how to install curl on Centos 5 whm/cpanel

  1. #1
    Join Date
    Oct 2008

    Post how to install curl on Centos 5 whm/cpanel

    i have new joomla autotranslation extension need curl software to be installed
    1 - go to software/install a RPM/curl 368
    2- go to update server /system software..... successfull
    3- go to rebuild RPM databse...successfull
    4- easy apache update and choose
    Previously Saved Config (** DEFAULT )
    then choose my default settings except i checked curl
    thensave and build....see this message
    Please help

    PHP Code:
    If the browser window is closed or stopped the build will continue in the background.
    The build output should start shortly...

    Distilled successfully
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1239567747' !!
    Ouput from '/bin/sh -c "ulimit -a"':
    core file size          (blocks, -c524288
    data seg size           
    (kbytes, -dunlimited
    scheduling priority             
    file size               
    (blocks, -funlimited
    pending signals                 
    max locked memory       
    (kbytes, -l32
    max memory size         
    (kbytes, -m524288
    open files                      
    pipe size            
    (512 bytes, -p8
    POSIX message queues     
    (bytes, -q819200
    -time priority              (-r0
    stack size              
    (kbytes, -s8192
    cpu time               
    (seconds, -tunlimited
    max user processes              
    virtual memory          
    (kbytes, -v524288
    file locks                      
    Creating backup of working apache in '/usr/local/apache.backup'. !!
    Symlink encountered (/usr/local/apache/etc), preserving target (conf)... !!
    Backup of working apache complete. !!
    Checking that all tarballs are present and up to date.
    Checking that all packages are present and up to date.
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
    Excluding Packages in 
    global exclude list
    Setting up Install Process
    Parsing package install arguments
    No package zlib1
    -devel available.
    Package expat-devel 1.95.8-8.2.1.i386 is already installed.
    Package gettext 0.14.6-4.el5.i386 is already installed.
    No package automake19 available.
    No package libopenssl0-dev available.
    Package expat 1.95.8-8.2.1.i386 is already installed.
    Package openssl 0.9.8e-7.el5.i686 is already installed.
    Package gcc-c++ - 4.1.2-44.el5.i386 is already installed.
    Requested depglibc-devel is provided by installed package
    Package zlib
    -devel 1.2.3-3.i386 is already installed.
    Package libstdc++ - 4.1.2-44.el5.i386 is already installed.
    Package zlib 1.2.3-3.i386 is already installed.
    Package bison 2.3-2.1.i386 is already installed.
    No package autoconf261 available.
    Package libidn 0.6.5-1.1.i386 is already installed.
    No package gmake available.
    Package libstdc++-devel 4.1.2-44.el5.i386 is already installed.
    Package openssl-devel 0.9.8e-7.el5.i386 is already installed.
    Package automake 1.9.6-2.1.noarch is already installed.
    No package libtool-libltdl-devel available.
    No package libopenssl0 available.
    No package openssl-dev available.
    Package libtool 1.5.22-6.1.i386 is already installed.
    No package libstdc++-dev available.
    No package libz-devel available.
    No package libltdl available.
    No package libltdl3-devel available.
    No package libopenssl0.9.7-static-devel available.
    No package pam-dev available.
    Package libtool-ltdl-devel 1.5.22-6.1.i386 is already installed.
    No package libopenssl0.9.7-devel available.
    Requested depfileutils is provided by installed package
    No package libltdl
    -devel available.
    Package sed 4.1.5-5.fc6.i386 is already installed.
    Package lsof 4.78-3.i386 is already installed.
    No package krb5-dev available.
    Package flex 2.5.4a-41.fc6.i386 is already installed.
    No package glibc-dev available.
    No package expat-dev available.
    Package make 1:3.81-3.el5.i386 is already installed.
    Package libtool-ltdl 1.5.22-6.1.i386 is already installed.
    No package libssl-dev available.
    Package cpp 4.1.2-44.el5.i386 is already installed.
    Package gcc 4.1.2-44.el5.i386 is already installed.
    No package libopenssl0-devel available.
    No package ssl-dev available.
    No package lex available.
    Package autoconf 2.59-12.noarch is already installed.
    Resolving Dependencies
    --> Running transaction check
    ---> Package libidn-devel.i386 0:0.6.5-1.1 set to be updated
    ---> Package patch.i386 0:2.5.4-29.2.3.el5 set to be updated
    ---> Package coreutils.i386 0:5.97-19.el5 set to be updated
    ---> Package krb5-devel.i386 0:1.6.1-31.el5_3.3 set to be updated
    --> Processing Dependencykrb5-libs 1.6.1-31.el5_3.3 for packagekrb5-devel
    ---> Package e2fsprogs-devel.i386 0:1.39-20.el5 set to be updated
    --> Processing Dependencye2fsprogs-libs 1.39-20.el5 for packagee2fsprogs-devel
    ---> Package pam-devel.i386 0: set to be updated
    --> Processing Dependencypam for packagepam-devel
    --> Running transaction check
    ---> Package krb5-libs.i386 0:1.6.1-31.el5_3.3 set to be updated
    --> Processing Dependencye2fsprogs-libs 1.39-15.el5 for packagee2fsprogs
    ---> Package e2fsprogs-libs.i386 0:1.39-20.el5 set to be updated
    ---> Package pam-devel.i386 0: set to be updated
    --> Processing Dependencypam for packagepam-devel
    --> Running transaction check
    ---> Package e2fsprogs.i386 0:1.39-20.el5 set to be updated
    ---> Package pam-devel.i386 0: set to be updated
    --> Processing Dependencypam for packagepam-devel
    --> Finished Dependency Resolution
    Missing Dependencypam is needed by package pam-devel
    !! ensure() rc was '0', exit status was '256'perl '$?' was '0', exit sig '0'core dump'0'shell '$?' was '1' !!
    Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!
    Could not ensure pkglist 'zlib1-devel, expat-devel, gettext, automake19, libopenssl0-dev, expat, openssl, gcc-c++, glibc-devel, zlib-devel, libstdc++, zlib, bison, autoconf261, libidn-devel, libidn, gmake, libstdc++-devel, openssl-devel, automake, coreutils, libtool-libltdl-devel, libopenssl0, openssl-dev, libtool, patch, libstdc++-dev, libz-devel, libltdl, libltdl3-devel, libopenssl0.9.7-static-devel, pam-dev, libtool-ltdl-devel, libopenssl0.9.7-devel, fileutils, libltdl-devel, e2fsprogs-devel, sed, lsof, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, make, libtool-ltdl, libssl-dev, pam-devel, cpp, gcc, libopenssl0-devel, ssl-dev, lex, autoconf' !!
    The server's system package manager, 'YUM', failed. !!
    This is the command that failed: yum --exclude=kernel* -y install zlib1-devel expat-devel gettext automake19 libopenssl0-dev expat openssl gcc-c++ glibc-devel zlib-devel libstdc++ zlib bison autoconf261 libidn-devel libidn gmake libstdc++-devel openssl-devel automake coreutils libtool-libltdl-devel libopenssl0 openssl-dev libtool patch libstdc++-dev libz-devel libltdl libltdl3-devel libopenssl0.9.7-static-devel pam-dev libtool-ltdl-devel libopenssl0.9.7-devel fileutils libltdl-devel e2fsprogs-devel sed lsof krb5-dev flex glibc-dev expat-dev krb5-devel make libtool-ltdl libssl-dev pam-devel cpp gcc libopenssl0-devel ssl-dev lex autoconf !!
    Since EasyApache was unable to resolve it automatically you should: 1) Manually run the failed YUM command (shown above) via SSH 2) See if your particular error is addressed at 3) Resolve the YUM problem manually 4) Re-run EasyApache !!
    !! Please visit for help with this error. !!
    !! Restoring original working apache !!
    !! Executing '
    /scripts/initsslhttpd' !!
    !! Restarting '
    httpd' ... !!
    !! '
    httpd' restart complete. !!
    !! Executing '
    /scripts/initfpsuexec' !!
    !! Executing '
    /scripts/initsslhttpd' !!
    Compiling report...
    Sending report (4813 bytes)...
    !! If you want to create a support ticket with cPanel regarding this please reference '
    BuildAP Report Id': '1906953' !!
    Report processed.
    !! Verbose logfile is at '
    /usr/local/cpanel/logs/easy/apache/build.1239567747' !! 

  2. #2
    Join Date
    Oct 2007


    Hmm not sure , but check this topic maybe will help you :

  3. #3
    Join Date
    Oct 2008


    i want to knowwhere can i find support !!!!

    when send ticket no throw my vpslink control panel,, they always say we are unmanaged server
    2- wiki has no detailed information, only som pic and titles
    3- form with no support

    so how to get suppor here !!!

  4. #4
    Join Date
    Jun 2008


    Quote Originally Posted by HEMA View Post
    i want to knowwhere can i find support !!!!

    when send ticket no throw my vpslink control panel,, they always say we are unmanaged server
    2- wiki has no detailed information, only som pic and titles
    3- form with no support

    so how to get suppor here !!!
    It seems like the likely reason is that PAM is in the yum.conf exclude list, so run this to remove it:
    sed -i -e's/^exclude=.*//' /etc/yum.conf; yum update
    If you are not already aware, VPSLink's service is unmanaged or self-managed, meaning that you are responsible for the software that runs within your VPS. Any support you get on the Forums, Wiki, etc is completely voluntary.
    Note: my views are my own and do not reflect those of VPSLink


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts