Results 1 to 6 of 6

Thread: cpan problem with Term::ReadLine

  1. #1
    Join Date
    May 2009
    Posts
    3

    Default cpan problem with Term::ReadLine

    Hello all,

    I am facing problems with cpan / cpanp:

    Code:
    demotionhermes ~ # cpan
    Cannot open sys$command for read at /usr/lib/perl5/5.8.8/CPAN.pm line 248
    After a lot of googling I found that this is a problem with missing /dev/tty and that is why Term::ReadLine cannot determine the OS...

    Any suggestions?
    Thanx in advance!

  2. #2
    Join Date
    Dec 2007
    Posts
    1,141

    Default

    My apologies for the delay in my reply - have you tried running cd /dev && MAKEDEV tty to create the device?

  3. #3
    Join Date
    May 2009
    Posts
    3

    Default

    Quote Originally Posted by DanL@VPSLink View Post
    My apologies for the delay in my reply - have you tried running cd /dev && MAKEDEV tty to create the device?
    Hello, thanx for the reply.
    I tried it without any success:

    Code:
    # cd /dev && MAKEDEV tty
    /usr/sbin/MAKEDEV: warning: can't read /proc/devices
    /usr/sbin/MAKEDEV: don't know how to make device "tty"

  4. #4
    Join Date
    Dec 2007
    Posts
    1,141

    Default

    Are you running under the root account?

    Is /proc mounted?

    What do the following commands yield?

    • mknod /dev/tty c 5 0
    • chmod 666 /dev/tty
    • chown root:root /dev/tty

  5. #5
    Join Date
    May 2009
    Posts
    3

    Default

    Thank you very much!
    I ran the commands you posted and everything is now normal!

    Thanx again!

  6. #6
    Join Date
    Mar 2011
    Location
    San Diego,Ca
    Posts
    1

    Default

    hey me too use that method that's pretty cool man

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •